Bonjour cher client CalGnome,

Il y a quelques jours, j'ai appris - malheureusement, que la communication de données entre les périphériques LX7/8/9nnn et le CalGnome pose un problème.

À ce stade, mes notes concernant votre commande de CalGnome ne me permettent pas de voir si vous utilisez ou non un LX7/8/9nnn avec FLARM intégré comme source du flux de données FLARM alimentant le CalGnome.

Si ce n'est pas le cas, vous pouvez ignorer ce courrier.

Si, toutefois, vous exécutez une telle configuration dans votre avion (ou souhaitez exécuter une conversion d'instrument à l'avenir), vous êtes concerné par ce problème.

 

Les périphériques LX7/8/9nnn n'émulent pas le flux de données FLARM à 100%. Un flux de données NMEA est omis. Au lieu de cela, le LX envoie des phrases de données propriétaires. Le micrologiciel CalGnome dépend - était - dépendant de cette flux de données spécifique, l’altitude de vol étant déduite de ce flux.

Il y a quatre ans, alors que le développement de CalGnome en était à sa phase finale, LX-Red-Boxes et diverses autres sources de données LX FLARM étaient compatibles à 100% avec le logiciel FLARM d'origine et le sont toujours. C’est pourquoi, apparemment trop naïf, j’ai supposé que les périphériques LX8/9nnn étaient également conformes à cette norme FLARM. Comme j'ai appris récemment, ils ne le sont pas.
Jusqu'ici la mauvaise nouvelle.

Maintenant la bonne nouvelle:
En attendant, j'ai changé et mis à jour le programme CalGnome de telle sorte que le programme ne soit plus dépendant de ce flux. L'altitude est maintenant dérivée d'un autre flux de données. La seule "réaction" est que la précision de l'altitude est maintenant exprimée en mètres, et non en pieds comme auparavant. Je suis sûr que cela ne nuit pas à la convivialité de CalGnome. 

C'est pourquoi je vous demande de me rendre le CalGnome. Je mettrai à jour le micrologiciel et vous renverrai le CalGnome dès que possible et sans frais supplémentaires.  

Les réponses à quelques questions évidentes à l’avance:
Le flux de données FLARM en cours de routage via le moteur de calcul n'est pas affecté par la mise à jour.
Les calculatrices qui ont reçu la mise à jour ne sont pas limitées dans leur utilisation des périphériques LX en tant que sources de données FLARM.
Ils restent entièrement compatibles avec les autres sources de données FLARM.

Je m'excuse sincèrement pour les ennuis que cela à pu crée.

Cordialement  

Horst Rupp

Version 8 ---- Copyright © 2008 - 2018  Horst Rupp